Ticket #232 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Sensors tab not visible due to "QtDesktop" not being installed

Reported by: peter andersson <lugiber@…> Owned by:
Priority: major Milestone:
Component: TelldusCenter Version: 2.1.1
Keywords: Cc:
Blocked By: Blocking:
Platform: Linux Sensitive: no
Verified by Telldus: no

Description

Summary:
When i start TelldusCenter i get the following error message:

file:///usr/lib/telldus/tellduscenter/plugins/script/com/telldus/sensors/main.qml:2:1: module "QtDesktop" is not installed
     import QtDesktop 0.1 

Because of this the sensors tab remains completely empty. My sensors are detected with "tdtool -l".

What i have done:
1.) Wiped data of both telldus-core and tellduscenter
2.) Downloaded and compiled from source
None of this have helped.
Unfortunatly i can't write a single line of code so there is no way for me to fix this.

My software specs:
OS: Ubuntu 12.04
QT: 4.8.1

Let me know if there is any way i can help out with resolving this.

Thanks

Change History

comment:1 Changed 7 years ago by peter andersson <lugiber@…>

Perhaps i should have made clear that i really don't care if the sensors doesn't show on TelldusCenter.
The important thing is to have them show up on Telldus Live.
So if i can make a request, please fix Live before Center.

comment:2 Changed 7 years ago by micke prag <micke.prag@…>

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #186

comment:3 Changed 7 years ago by peter andersson <lugiber@…>

Well, I believe that this bug should still be open.
Tellduscenter is still not working properly under debian/ubuntu/linux, the sensors menu still remains empty. And that needs to be fixed no matter if telldus live does support sensor info yet or not. And when telldus live starts to support sensors I guess it would still rely on information from Tellduscenter (at least if things keeps working as they do with the switches).

Last edited 7 years ago by peter andersson <lugiber@…> (previous) (diff)

comment:4 Changed 7 years ago by micke prag <micke.prag@…>

  • Status changed from closed to reopened
  • Resolution duplicate deleted

You are missing the QtDesktop module in TelldusCenter. It seems it didn't get compiled. What steps did you use when compiling from source?
Did you compile directly from Git och a source package?

comment:5 Changed 7 years ago by peter andersson <lugiber@…>

I compiled it the same way i compiled telldus-core. Eg. cmake, make, sudo make install.
And the QtDesktop module is compiled.
But for it to work i had to add this repo:

 https://launchpad.net/~forumnokia/+archive/fn-ppa

And then install qt-components-desktop from there. Perhaps that just worked as a replacement for the qtdesktop that gets compiled when tellduscenter is properly compiled/configured.

I'm not using the git, i downloaded the source packages from your site.

Regardless of that i'm still not getting sensor information in the android app. And that app gets all information from telldus live.
So, something is still not working as it should.

Let me know if you need more information and i'll provide it!

Thanks for your help!

comment:6 Changed 7 years ago by micke prag <micke.prag@…>

  • Status changed from reopened to closed
  • Resolution set to fixed

Great that installing qt-components-desktop solved the problem.

Note: See TracTickets for help on using tickets.