Ticket #235 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Arctech transmitters send different codes for ON and OFF

Reported by: Carsten <carsten.cremer@…> Owned by:
Priority: major Milestone: 2.1.2
Component: telldus-core Version: 2.1.1
Keywords: Cc:
Blocked By: Blocking:
Platform: All Sensitive: no
Verified by Telldus: no

Description

Some transmitters are detected with different remote code for ON and OFF. For instance:
54860582/3 for ON and
7623090/10 for OFF

or
54837414/12 for ON and
7621642/10 for OFF

The bitpattern is quite similar so it might be a but in TellStick Duo/Net firmware.

Attachments

93098968.png Download (16.0 KB) - added by bob foster <smartmil888@…> 2 years ago.
 http://smartmiltoys.com/kidkraft-train-table/

Change History

comment:1 Changed 6 years ago by fredrik lindell <fredrik.lindell@…>

I have the same problem using a Nexa LMST-606 Magnetic Proximity Switch.

Mapping it straight to an self-learning receiver is no problem.

comment:2 Changed 6 years ago by tobias bohm <tobbebohm@…>

Same problem here.
Raw callbacks from an LMST-606 looks like this:

class:command;protocol:arctech;model:selflearning;house:7358550;unit:10;group:0;method:turnoff;
class:command;protocol:sartano;model:codeswitch;code:0110111001;method:turnoff;

class:command;protocol:arctech;model:selflearning;house:50627942;unit:8;group:0;method:turnon;
class:command;protocol:sartano;model:codeswitch;code:0001011001;method:turnon;

comment:3 Changed 6 years ago by peter fassberg <peter@…>

On the lower level you find this:

+Wprotocol:arctech;model:selflearning;data:0x1EA84489;
+Wprotocol:arctech;model:selflearning;data:0xEA84499D;

The first example has a leading (erroneous?) "1" and the second example has en extra ending "D" (that is 32 bit). This seems more correct:

+Wprotocol:arctech;model:selflearning;data:0xEA84489;
+Wprotocol:arctech;model:selflearning;data:0xEA84499;

This is probably a decoding error in the firmware.

comment:4 Changed 5 years ago by daniel malmgren <daniel.malmgren.dm@…>

Any response from Telldus on this? The LMST-606 is really not usable as it is now and if it's a firmware bug it's hard for anyone else to do anything about it.

comment:5 Changed 5 years ago by stefan persson <stefan.persson@…>

  • Status changed from new to closed
  • Resolution set to fixed

Firmware updates (beta) that addresses this bug:

TellStick Duo:
 http://telld.us/rdlq4

TellStick Net:
 http://telld.us/jvwuv

Note that this beta firmware contain some other changes too, for example improved Oregon reception for TellStick Net (possible issue with Oregon in TellStick Duo, we're looking into this). Please report any regression issues. If you need to go back to an older firmware, download them from here:  http://download.telldus.com/TellStick/Software/firmware/

How to update:
Tellstick Duo:
Use the flasher tool in the TelldusCenter installation folder on Windows. Drag-and-drop the firmware-file to the TellStickFlasher-icon. Select your TellStick Duo in the list, and ignore that it says that it's already up to date. If you run the flasher-tool again, it should report the firmware version as 6.

TellStick Net:
Use the flasher tool (for windows,  http://download.telldus.com/TellStick/Software/TellStickNetFlasher/TellStickNetFlasher.zip ), to upgrade. Drag-and-drop the firmware-file to the TellStickNetFlasher-icon. Select your TellStick Net in the list, and ignore that it says that it's already up to date.

Alternatively, follow the instuctions here: http://developer.telldus.com/wiki/Firmware

If you then go to "My locations" in Telldus Live!, your firmware version should be reported as 6.

Last edited 5 years ago by stefan persson <stefan.persson@…> (previous) (diff)

comment:6 Changed 5 years ago by daniel malmgren <daniel.malmgren.dm@…>

Flashed the firmware to try it out. What happened though was that none of my switches worked anymore. I got the red blink from my Duo when doing a "tdtool --on whatever" but no reaction from the switches. So I'm back to firmware 4 again. Never got as far as to try out the magnet switch...

Edit: I realize it might be good with a bit of more information. I'm running on an Excito B3 running Debian Squeeze and telldus-core version 2.1.1-1 from the repository.

Last edited 5 years ago by daniel malmgren <daniel.malmgren.dm@…> (previous) (diff)

comment:7 Changed 5 years ago by fredrik lindell <fredrik.lindell@…>

Just tried the new beta firmware and it seems to be working fine for me.

Edit:
Nope I was to excited. All my data sources works like a charm but i can´t control any of my receivers. Reverting the firmware upgrade...

Last edited 5 years ago by fredrik lindell <fredrik.lindell@…> (previous) (diff)

comment:8 Changed 5 years ago by tobias bohm <tobbebohm@…>

Flashed my duo with Beta6 firmware, same problem as others have, cannot control any recievers. However, the magnetic switch events seems to work.

Changed back to fw4 then fw5, recievers working. Magnetic switch does not.

Running on Windows server 2003, telldus version 2.1.1

comment:9 Changed 5 years ago by fredrik lindell <fredrik.lindell@…>

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:10 Changed 5 years ago by stefan persson <stefan.persson@…>

  • Status changed from reopened to closed
  • Resolution set to fixed

The TellStick Duo firmware is now updated (see link in earlier post). The problem with the last one had to do with a hard-to-track-down compiler issue, sorry about that.

Reports about better or worse Oregon reception are still welcome.

comment:11 Changed 5 years ago by fredrik lindell <fredrik.lindell@…>

Thank you. I just tested my Nexa LMST-606 and they are working just fine. I have also tested all my receivers and they are also working this time.

I don´t have any Oregon devices so cant say anything about them.

comment:12 Changed 5 years ago by daniel malmgren <daniel.malmgren.dm@…>

Yep, everything seems to work fine with beta7 for me as well, both the LMST-606 and everything else. Just as Fredrik I only have a LMST-606 though, can't tell anything about Oregon.

comment:13 Changed 5 years ago by tobias bohm <tobbebohm@…>

I can confirm that my Duo now works as it should with the LMST-606 and other receivers, thank you.

Changed 2 years ago by bob foster <smartmil888@…>

Note: See TracTickets for help on using tickets.