Ticket #509 (new defect)

Opened 2 months ago

Last modified 2 months ago

Unable to run tellstick-server

Reported by: knut olav bøhmer <bohmer@…> Owned by:
Priority: major Milestone:
Component: other Version:
Keywords: Cc:
Blocked By: Blocking:
Platform: Linux Sensitive: no
Verified by Telldus: no

Description

(.env) ❰knobo❙~/usr/src/telldus/tellstick-server(git:master)❱✔≻ ./tellstick.sh setup
Create virtualenv
created virtual environment CPython2.7.18.candidate.1-64 in 242ms

creator CPython2Posix(dest=/home/knobo/usr/src/telldus/tellstick-server/build/env, clear=False, global=False)
seeder FromAppData(download=False, contextlib2=latest, requests=latest, colorama=latest, certifi=latest, packaging=latest, lockfile=latest, pyparsing=latest, six=latest, distro=latest, idna=latest, webencodings=latest, CacheControl=latest, pkg_resources=latest, progress=latest, pep517=latest, retrying=latest, wheel=latest, html5lib=latest, ipaddr=latest, pip=latest, pytoml=latest, distlib=latest, urllib3=latest, setuptools=latest, msgpack=latest, appdirs=latest, chardet=latest, via=copy, app_data_dir=/home/knobo/.local/share/virtualenv/seed-app-data/v1.0.1.debian)
activators BashActivator,CShellActivator,FishActivator,PowerShellActivator,PythonActivator

DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at  https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Collecting pip

Using cached pip-20.1.1-py2.py3-none-any.whl (1.5 MB)

Installing collected packages: pip

Attempting uninstall: pip

Found existing installation: pip 20.0.2
Uninstalling pip-20.0.2:

Successfully uninstalled pip-20.0.2

Successfully installed pip-20.1.1
Setting up environment
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at  https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Processing /home/knobo/.cache/pip/wheels/59/5b/88/3ff7cb7f1cb9dbb3649c537e7b987203e0ad71a89533f0f7f3/captainhook-0.8.7-py2-none-any.whl
Collecting freezegun

Using cached freezegun-0.3.15-py2.py3-none-any.whl (14 kB)

Collecting mock

Using cached mock-3.0.5-py2.py3-none-any.whl (25 kB)

Collecting pylint

Using cached pylint-1.9.5-py2.py3-none-any.whl (696 kB)

Collecting python-dateutil

Using cached python_dateutil-2.8.1-py2.py3-none-any.whl (227 kB)

Collecting tzlocal

Using cached tzlocal-2.1-py2.py3-none-any.whl (16 kB)

Collecting flake8

Using cached flake8-3.8.2-py2.py3-none-any.whl (72 kB)

Processing /home/knobo/.cache/pip/wheels/0a/ab/01/3cb99bbaa0662465dc448e56f0130ff49b9006a95793397c3a/docopt-0.6.1-py2-none-any.whl
Collecting isort>=4.1.1

Using cached isort-4.3.21-py2.py3-none-any.whl (42 kB)

Processing /home/knobo/.cache/pip/wheels/64/c5/38/0b90de8ab6eeab2af3976603cc5434f8d6bed248707718f476/bash-0.6-py2-none-any.whl
Requirement already satisfied, skipping upgrade: six in ./build/env/lib/python2.7/site-packages (from freezegun->-r requirements.txt (line 2)) (1.14.0)
Collecting funcsigs>=1; python_version < "3.3"

Using cached funcsigs-1.0.2-py2.py3-none-any.whl (17 kB)

Collecting mccabe

Using cached mccabe-0.6.1-py2.py3-none-any.whl (8.6 kB)

Collecting singledispatch; python_version < "3.4"

Using cached singledispatch-3.4.0.3-py2.py3-none-any.whl (12 kB)

Collecting backports.functools-lru-cache; python_version == "2.7"

Using cached backports.functools_lru_cache-1.6.1-py2.py3-none-any.whl (5.7 kB)

Collecting astroid<2.0,>=1.6

Using cached astroid-1.6.6-py2.py3-none-any.whl (305 kB)

Collecting configparser; python_version == "2.7"

Using cached configparser-4.0.2-py2.py3-none-any.whl (22 kB)

Collecting pytz

Using cached pytz-2020.1-py2.py3-none-any.whl (510 kB)

Collecting typing; python_version < "3.5"

Using cached typing-3.7.4.1-py2-none-any.whl (26 kB)

Collecting importlib-metadata; python_version < "3.8"

Using cached importlib_metadata-1.6.0-py2.py3-none-any.whl (30 kB)

Processing /home/knobo/.cache/pip/wheels/c2/ea/a3/25af52265fad6418a74df0b8d9ca8b89e0b3735dbd4d0d3794/functools32-3.2.3.post2-py2-none-any.whl
Collecting pyflakes<2.3.0,>=2.2.0

Using cached pyflakes-2.2.0-py2.py3-none-any.whl (66 kB)

Collecting pycodestyle<2.7.0,>=2.6.0a1

Using cached pycodestyle-2.6.0-py2.py3-none-any.whl (41 kB)

Collecting enum34; python_version < "3.4"

Using cached enum34-1.1.10-py2-none-any.whl (11 kB)

Collecting futures; python_version < "3.2"

Using cached futures-3.3.0-py2-none-any.whl (16 kB)

Processing /home/knobo/.cache/pip/wheels/5b/d8/8e/81a83cb5321b940a954996f5b57fddc8976e712b3ac3a1a54b/wrapt-1.12.1-py2-none-any.whl
Collecting lazy-object-proxy

Downloading lazy_object_proxy-1.5.0-cp27-cp27mu-manylinux1_x86_64.whl (55 kB)

|████████████████████████████████| 55 kB 1.2 MB/s

Requirement already satisfied, skipping upgrade: contextlib2; python_version < "3" in ./build/env/lib/python2.7/site-packages (from importlib-metadata; python_version < "3.8"->flake8->captainhook->-r requirements.txt (line 1)) (0.6.0)
Collecting pathlib2; python_version < "3"

Using cached pathlib2-2.3.5-py2.py3-none-any.whl (18 kB)

Collecting zipp>=0.5

Using cached zipp-1.2.0-py2.py3-none-any.whl (4.8 kB)

Processing /home/knobo/.cache/pip/wheels/58/2c/26/52406f7d1f19bcc47a6fbd1037a5f293492f5cf1d58c539edb/scandir-1.10.0-cp27-cp27mu-linux_x86_64.whl
Installing collected packages: typing, scandir, pathlib2, configparser, zipp, importlib-metadata, functools32, pyflakes, pycodestyle, enum34, mccabe, flake8, docopt, futures, backports.functools-lru-cache, isort, bash, captainhook, python-dateutil, freezegun, funcsigs, mock, singledispatch, wrapt, lazy-object-proxy, astroid, pylint, pytz, tzlocal
Successfully installed astroid-1.6.6 backports.functools-lru-cache-1.6.1 bash-0.6 captainhook-0.8.7 configparser-4.0.2 docopt-0.6.1 enum34-1.1.10 flake8-3.8.2 freezegun-0.3.15 funcsigs-1.0.2 functools32-3.2.3.post2 futures-3.3.0 importlib-metadata-1.6.0 isort-4.3.21 lazy-object-proxy-1.5.0 mccabe-0.6.1 mock-3.0.5 pathlib2-2.3.5 pycodestyle-2.6.0 pyflakes-2.2.0 pylint-1.9.5 python-dateutil-2.8.1 pytz-2020.1 scandir-1.10.0 singledispatch-3.4.0.3 typing-3.7.4.1 tzlocal-2.1 wrapt-1.12.1 zipp-1.2.0
Installing plugin /home/knobo/usr/src/telldus/tellstick-server/api
Install requirements
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at  https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Collecting cryptography

Using cached cryptography-2.9.2-cp27-cp27mu-manylinux2010_x86_64.whl (2.7 MB)

Collecting python-jose

Using cached python_jose-3.1.0-py2.py3-none-any.whl (26 kB)

Requirement already satisfied, skipping upgrade: enum34; python_version < "3" in /home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages (from cryptography->-r /home/knobo/usr/src/telldus/tellstick-server/api/requirements.txt (line 1)) (1.1.10)
Requirement already satisfied, skipping upgrade: six>=1.4.1 in /home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages (from cryptography->-r /home/knobo/usr/src/telldus/tellstick-server/api/requirements.txt (line 1)) (1.14.0)
Collecting ipaddress; python_version < "3"

Using cached ipaddress-1.0.23-py2.py3-none-any.whl (18 kB)

Collecting cffi!=1.11.3,>=1.8

Using cached cffi-1.14.0-cp27-cp27mu-manylinux1_x86_64.whl (387 kB)

Collecting rsa

Using cached rsa-4.0-py2.py3-none-any.whl (38 kB)

Collecting ecdsa<1.0

Using cached ecdsa-0.15-py2.py3-none-any.whl (100 kB)

Collecting pyasn1

Using cached pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)

Collecting pycparser

Using cached pycparser-2.20-py2.py3-none-any.whl (112 kB)

Installing collected packages: ipaddress, pycparser, cffi, cryptography, pyasn1, rsa, ecdsa, python-jose
Successfully installed cffi-1.14.0 cryptography-2.9.2 ecdsa-0.15 ipaddress-1.0.23 pyasn1-0.4.8 pycparser-2.20 python-jose-3.1.0 rsa-4.0
Installing plugin /home/knobo/usr/src/telldus/tellstick-server/base
Install requirements
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at  https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Processing /home/knobo/.cache/pip/wheels/c1/12/7a/c676d85d30d1aa17f3882dab925a777ab1f651c4072cccefd7/configobj-5.0.6-py2-none-any.whl
Requirement already satisfied, skipping upgrade: six in /home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages (from configobj->-r /home/knobo/usr/src/telldus/tellstick-server/base/requirements.txt (line 1)) (1.14.0)
Installing collected packages: configobj
Successfully installed configobj-5.0.6
Installing plugin /home/knobo/usr/src/telldus/tellstick-server/board
Installing plugin /home/knobo/usr/src/telldus/tellstick-server/developer
Installing plugin /home/knobo/usr/src/telldus/tellstick-server/live
Install requirements
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at  https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Collecting netifaces

Using cached netifaces-0.10.9-cp27-cp27mu-manylinux1_x86_64.whl (31 kB)

Processing /home/knobo/.cache/pip/wheels/8e/4d/9e/2319091bc90a29463fef88a342ba923ba6931594a651ec84c3/pbkdf2-1.3-py2-none-any.whl
Processing /home/knobo/.cache/pip/wheels/b6/e6/c8/d1eca13628952ceec1d40d96e0a7a1380460d2349ce0b85312/pycrypto-2.6.1-cp27-cp27mu-linux_x86_64.whl
Processing /home/knobo/.cache/pip/wheels/3c/ac/32/1ef0006e08d6e7e9c8c08bd4ce053a405543ae05b43a4e6447/python_openid-2.2.5-py2-none-any.whl
Collecting requests

Using cached requests-2.23.0-py2.py3-none-any.whl (58 kB)

Requirement already satisfied, skipping upgrade: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages (from requests->-r /home/knobo/usr/src/telldus/tellstick-server/live/requirements.txt (line 5)) (1.25.8)
Requirement already satisfied, skipping upgrade: certifi>=2017.4.17 in /home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages (from requests->-r /home/knobo/usr/src/telldus/tellstick-server/live/requirements.txt (line 5)) (2019.11.28)
Requirement already satisfied, skipping upgrade: chardet<4,>=3.0.2 in /home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages (from requests->-r /home/knobo/usr/src/telldus/tellstick-server/live/requirements.txt (line 5)) (3.0.4)
Requirement already satisfied, skipping upgrade: idna<3,>=2.5 in /home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages (from requests->-r /home/knobo/usr/src/telldus/tellstick-server/live/requirements.txt (line 5)) (2.8)
Installing collected packages: netifaces, pbkdf2, pycrypto, python-openid, requests

Attempting uninstall: requests

Found existing installation: requests 2.22.0
Uninstalling requests-2.22.0:

Successfully uninstalled requests-2.22.0

Successfully installed netifaces-0.10.9 pbkdf2-1.3 pycrypto-2.6.1 python-openid-2.2.5 requests-2.23.0
Installing plugin /home/knobo/usr/src/telldus/tellstick-server/log
Installing plugin /home/knobo/usr/src/telldus/tellstick-server/sdk
Install requirements
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at  https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Collecting python-gnupg==0.4.0

Using cached python_gnupg-0.4.0-py2.py3-none-any.whl (14 kB)

WARNING: Installing from a newer Wheel-Version (1.1)
Processing /home/knobo/.cache/pip/wheels/d1/d5/a0/3c27cdc8b0209c5fc1385afeee936cf8a71e13d885388b4be2/PyYAML-5.3.1-cp27-cp27mu-linux_x86_64.whl
WARNING: Installing from a newer Wheel-Version (1.1)
Installing collected packages: python-gnupg, PyYAML

WARNING: Installing from a newer Wheel-Version (1.1)

Successfully installed PyYAML-5.3.1 python-gnupg-0.4.0
Installing plugin /home/knobo/usr/src/telldus/tellstick-server/telldus
Install npm packages
npm WARN deprecated babel-preset-es2015@6.24.1: 🙌 Thanks for using Babel: we recommend using babel-preset-env now: please read  https://babeljs.io/env to update!
npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
npm WARN deprecated core-js@1.2.7: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated resolve-url@0.2.1:  https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated urix@0.1.0: Please see  https://github.com/lydell/urix#deprecated
[ |[ ......] | extract:react-mdl: sill extract react-mdl@1.7.1 extracted to /home/knobo/usr/src/telld

core-js@2.6.11 postinstall /home/knobo/usr/src/telldus/tellstick-server/telldus/node_modules/core-js
node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js (  https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon:

 https://opencollective.com/core-js
 https://www.patreon.com/zloirock

Also, the author of core-js (  https://github.com/zloirock ) is looking for a good job -)

npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN notsup Unsupported engine for watchpack-chokidar2@2.0.0: wanted: {"node":"<8.10.0"} (current: {"node":"12.3.1","npm":"6.13.7"})
npm WARN notsup Not compatible with your version of node/npm: watchpack-chokidar2@2.0.0
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules/watchpack-chokidar2/node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@
1.2.7 (node_modules/webpack-dev-server/node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN tellstick-local-access@0.1.0 No description
npm WARN tellstick-local-access@0.1.0 No repository field.
npm WARN tellstick-local-access@0.1.0 No license field.

added 836 packages from 680 contributors and audited 840 packages in 26.387s

23 packages are looking for funding

run npm fund for details

found 4 vulnerabilities (2 low, 1 moderate, 1 high)

run npm audit fix to fix them, or npm audit for details

tellstick-local-access@0.1.0 build /home/knobo/usr/src/telldus/tellstick-server/telldus
webpack

Hash: 1abef7aa5fbcf4d93bec
Version: webpack 2.7.0
Time: 2893ms

Asset Size Chunks Chunk Names

fonts/telldusicons.eot 1.7 kB [emitted]

telldusicons.svg 216 kB [emitted]

fonts/MaterialIcons-Regular.eot 143 kB [emitted]
fonts/MaterialIcons-Regular.ttf 128 kB [emitted]

fonts/MaterialIcons-Regular.woff 57.6 kB [emitted]

fonts/MaterialIcons-Regular.woff2 44.3 kB [emitted]

fonts/telldusicons.ttf 29.6 kB [emitted]

fonts/telldusicons.woff 29.7 kB [emitted]

./js/main.entry.js 2.22 MB 0 [emitted] [big] main
./js/common.lib.js 30.6 kB 1 [emitted] common

[0] ./~/process/browser.js 5.42 kB {0} [built]
[1] ./~/react/react.js 56 bytes {0} [built]

[15] ./~/react-dom/index.js 59 bytes {0} [built]
[22] ./~/react-router/lib/RouteUtils.js 2.84 kB {0} [built]
[27] ./~/react-redux/lib/index.js 475 bytes {0} [built]
[37] ./~/redux/es/index.js 1.08 kB {0} [built]
[46] ./~/react-router/lib/index.js 4.6 kB {0} [built]
[66] ./~/redux-logger/lib/index.js 4.89 kB {0} [built]
[67] ./~/redux-thunk/es/index.js 481 bytes {0} [built]
[99] ./src/telldus/web/app/actions/components.jsx 755 bytes {0} [built]

[176] ./src/telldus/web/app/reducers/index.jsx 551 bytes {0} [built]
[177] (webpack)-material-design-icons/index.js 57 bytes {1} [built]
[178] ./~/whatwg-fetch/fetch.js 12.7 kB {1} [built]
[184] ./src/telldus/web/app/main.jsx 5.11 kB {0} [built]
[448] multi webpack-material-design-icons whatwg-fetch 40 bytes {1} [built]

+ 434 hidden modules

Installing plugin /home/knobo/usr/src/telldus/tellstick-server/web
Install requirements
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at  https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Collecting cherrypy==8.6.0

Using cached CherryPy-8.6.0-py2.py3-none-any.whl (463 kB)

Processing /home/knobo/.cache/pip/wheels/f8/d4/42/a6d3e7518c284facd0e06eebb3e670e51b4b7e8dcb1c4a49d9/Genshi-0.7.3-cp27-cp27mu-linux_x86_64.whl
Processing /home/knobo/.cache/pip/wheels/ed/08/21/d15ba62e01fca61666676e0f7c5a05be3f112d2f398b922e30/ws4py-0.5.1-py2-none-any.whl
Requirement already satisfied, skipping upgrade: six in /home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages (from cherrypy==8.6.0->-r /home/knobo/usr/src/telldus/tellstick-server/web/requirements.txt (line 1)) (1.14.0)
Installing collected packages: cherrypy, genshi, ws4py
Successfully installed cherrypy-8.6.0 genshi-0.7.3 ws4py-0.5.1
Installing captainhook-0.8.7
Installing pre_commit.py to /home/knobo/usr/src/telldus/tellstick-server/.git
Configuring pre-commit hook to use virtualenv
Installing check: utils.py
Installing check: grep.py
Installing check: merge_marks.py
Installing check: pylint_checker.py
Installing check: pytest_coverage_checker.py
Installing check: frosted_checker.py
Installing check: pylint_docstrings_checker.py
Installing check: block_branches.py
Installing check: pdb_checker.py
Installing check: isort_checker.py
Installing check: pytest_checker.py
Installing check: python3.py
Installing check: flake8_checker.py
Installing check: init.py
(.env) ❰knobo❙~/usr/src/telldus/tellstick-server(git:master)❱✔≻ ./tellstick.sh run
Starting server
CRITICAL:root:Could not load settings file: Empty config file
CRITICAL:root:Could not load backup settings file: No config bak file
ERROR:root:Could not load c = log:Logger [creq]
ERROR:root:'module' object has no attribute 'config'
ERROR:root:('/home/knobo/usr/src/telldus/tellstick-server/base/src/base/Application.py', 248, 'loadPkgResourses', 'moduleClass(self.pluginContext)')
ERROR:root:('/home/knobo/usr/src/telldus/tellstick-server/base/src/base/Plugin.py', 88, '
call', 'self.init()')
ERROR:root:('/home/knobo/usr/src/telldus/tellstick-server/log/src/log/Logger.py', 74, '
init', 'logging.config.dictConfig({')
[05/Jun/2020:12:47:40] ENGINE Bus STARTING
INFO:cherrypy.error:[05/Jun/2020:12:47:40] ENGINE Bus STARTING
[05/Jun/2020:12:47:40] ENGINE Starting WebSocket processing
INFO:cherrypy.error:[05/Jun/2020:12:47:40] ENGINE Starting WebSocket processing
[05/Jun/2020:12:47:40] ENGINE Started monitor thread '_TimeoutMonitor'.
INFO:cherrypy.error:[05/Jun/2020:12:47:40] ENGINE Started monitor thread '_TimeoutMonitor'.
[05/Jun/2020:12:47:40] ENGINE Serving on  http://:::8080
INFO:cherrypy.error:[05/Jun/2020:12:47:40] ENGINE Serving on  http://:::8080
[05/Jun/2020:12:47:40] ENGINE Bus STARTED
INFO:cherrypy.error:[05/Jun/2020:12:47:40] ENGINE Bus STARTED

Attachments

Screenshot from 2020-06-05 13-27-27.png Download (50.9 KB) - added by knut olav bøhmer <bohmer@…> 2 months ago.
Plugin-loader not awailable

Change History

Changed 2 months ago by knut olav bøhmer <bohmer@…>

Plugin-loader not awailable

comment:1 Changed 2 months ago by micke prag <micke.prag@…>

Please install the plugin-loader plugin with:
tellstick-sh install plugin-loader

comment:2 Changed 2 months ago by knut olav bøhmer <bohmer@…>

After insalling plugin-loader I got this:

ERROR:root:Could not load c = pluginloader:WebFrontend [creq]
ERROR:root:No module named rauth

knobo@float:~/usr/src/telldus/tellstick-server$ ./tellstick.sh install plugin-loader
Installing plugin from plugin-loader
Installing plugin /home/knobo/usr/src/telldus/tellstick-server/plugin-loader
Install requirements
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at  https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: python-gnupg==0.4.0 in /home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages (from -r /home/knobo/usr/src/telldus/tellstick-server/plugin-loader/requirements.txt (line 1)) (0.4.0)
Install npm packages
npm WARN plugin-loader@1.0.0 No description
npm WARN plugin-loader@1.0.0 No repository field.
npm WARN plugin-loader@1.0.0 No license field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

audited 503 packages in 3.092s

3 packages are looking for funding

run npm fund for details

found 11 vulnerabilities (3 low, 2 moderate, 6 high)

run npm audit fix to fix them, or npm audit for details

plugin-loader@1.0.0 build /home/knobo/usr/src/telldus/tellstick-server/plugin-loader
gulp

[10:21:26] Using gulpfile ~/usr/src/telldus/tellstick-server/plugin-loader/gulpfile.js
[10:21:26] Starting 'babel'...
[10:21:27] Finished 'babel' after 1.16 s
[10:21:27] Starting 'plugins'...
[10:21:27] Starting 'oauth2'...
[10:21:27] Optimizing oauth2.js
[10:21:28] Optimizing plugins.js
[10:21:28] Finished 'oauth2' after 804 ms
[10:21:28] Finished 'plugins' after 806 ms
[10:21:28] Starting 'default'...
[10:21:28] Finished 'default' after 23 μs

knobo@float:~/usr/src/telldus/tellstick-server$ ./tellstick.sh run

Starting server
ERROR:root:Could not load c = pluginloader:WebFrontend [creq]
ERROR:root:No module named rauth
ERROR:root:('/home/knobo/usr/src/telldus/tellstick-server/base/src/base/Application.py', 238, 'loadPkgResourses', 'moduleClass = entry.load()')
ERROR:root:('/home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages/pkg_resources/__init__.py', 2443, 'load', 'return self.resolve()')
ERROR:root:('/home/knobo/usr/src/telldus/tellstick-server/build/env/lib/python2.7/site-packages/pkg_resources/__init__.py', 2449, 'resolve', "module =
import(self.module_name, fromlist=__name__?, level=0)")
ERROR:root:('/home/knobo/usr/src/telldus/tellstick-server/plugin-loader/src/pluginloader/__init__.py', 3, '<module>', 'from .ConfigurationOAuth2 import ConfigurationOAuth2')
ERROR:root:('/home/knobo/usr/src/telldus/tellstick-server/plugin-loader/src/pluginloader/ConfigurationOAuth2.py', 6, '<module>', 'import rauth')
CRITICAL:root:Could not load settings file: Empty config file
CRITICAL:root:Could not load backup settings file: No config bak file
ERROR:root:Could not load c = log:Logger [creq]
ERROR:root:'module' object has no attribute 'config'
ERROR:root:('/home/knobo/usr/src/telldus/tellstick-server/base/src/base/Application.py', 248, '
loadPkgResourses', 'moduleClass(self.pluginContext)')

Note: See TracTickets for help on using tickets.